Saved Changes Lost on Reload

I have purchased this application to modify EXIF/XMP Lens information. When I launch the application, App Store v2.0.8, it loads the information, and I can edit it, and it saves without error. I tried to reload the metadata in LightRoom and it didn’t show the changes. I reloaded the file in MetaImage and it went back the the original values. I then tried again using the Edit Raw Value option from the editor, same outcome. I am trying to modify a DNG file. I’ve tried DNG files from two different cameras with the same outcome.

I searched on the forum, and I found this post. It seems to indicate the solution is to remove the metadata and then try to apply it again. I tried again. I double clicked the value, selected the delete option. Selected Save All Files, right click reload and the value is back to how it was originally set by the camera.

I have quit the app, granted full disk access from System Preferences and tried again. I tried DNG’s from two different cameras with the same outcome as well.

1 Like

I did not use the App for a while, I need to share some RAW and want to clean some meta.
I’m macOS 12.5 and when I save it seems everything it is OK but if I reopen my file EXIF are back as they was before editing

The source of the problem is the creation of the backup folder failing, which was not created for some technical reasons related to the sandbox.

Here is the solution. Version 2.0.9 will fix the problem. I have already uploaded it on all platforms. It may take a few days to be reviewed by the Mac App Store team.



Thank you so much! I have applied the update and confirmed the saved changes are persistent and show in Lightroom as I was hoping they would. I also really appreciate the quick response. Love your application.


1 Like