MetaImage not reading Date/time EXIF data

Hi, I’m using MetaImage 2.0.9 (6160) and I cannot figure out what’s going on.

I cannot get MetaImage to read already existing EXIF data (and it’s questionable if it’s actually writing them as well).

I have a photo that was taken in July of 2019, and by using 3 other tools I can see that it has the EXIF dateTimeOriginal set to 2019:07:30 15:56:25. MetaImage does not pick this up in the UI for some reason.

I’ve tried to attach screenshots showing the other tools and the results from MetaImage, but I can only put one in my post.


Please advise.

Screenshot from Preview:
Screen Shot 2022-08-09 at 4.24.18 PM

exiftools (Linux CLI):
Screen Shot 2022-08-09 at 4.23.07 PM

Photos EXIF Editor:

Hello there,

Thank you for the feedback.

Is it possible to send me a copy of the image and/or on this thread? I will try to reproduce the problem to investigate.

MetaImage 2 includes a new view mode to inspect your files. Is the date displayed?


I just sent an email with the file. I’ve checked a number of files that have EXIF metadata all with the same results, show fine in other tools just not MetaImage.

When going into the Metadata Comparator it does not show a date.

I’m also not seeing GPS metadata for other files that have it.

I just updated to 2.0.10 (6167) and it appears that the issue is fixed! (Didn’t realize there was an update :smiley: )

I’ll continue testing and let you know if I run into anything else.



Thank you for the feedback.

Do not hesitate to contact me if you have other issues or if you want to propose improvements