MetaImage does not open any file. Full Disk Access is granted

When trying to open any image I get this error, please see attached screenshot.
Please advise.

Hello Alva,

I am sorry for the problem.

Are you using the latest version of MetaImage?
Did the error occur when you move the file in an other folder?

Have a nice day,

Fixed. The folder had a couple of icons in the name, once I removed the icons it all worked.

Thanks for the feedback! I’ll look into why using Emojis in filenames is causing issues.

I seem to be unable to load more than about 300 photos into MetaImage at a time. If I select more photos than that it imports none, yet the progress bar count from 0-100% as if it is trying to import the images. I have granted full disk access and I am using the MetaImage downloaded from the NeededApps website. I tried adding 300 images repeatingly in MetaImage until I could no longer add any more images. The program stopped adding more photos when I had 1737 images added. Each image is between 2.5 and 3 MB. I am using a Apple Silicon MacBook Pro.

Does it happen only from the latest update and for a moment?

It has been a while since I tried using MetaImage with this amount of images, but it used to work just fine last year in the unsandboxed version from the NeededApps website.

Thanks I will investigate.