Issues creating a gif on a M1 Mac Mini on Monterey (SnapMotion 5.x)


So I tried making a gif and exporting it to a folder. However, no matter the combination of settings, it makes a gif but macOS refuses to open it saying that the gif is empty without any other explanation. Even after the process is supposed to be done. I’m attaching a picture of my settings in order to help maybe diagnose some weird gif settings?

Thank you very much for the feedback.

Do you have the same problem if you extract less images?


Nope. No matter how I tried to change the gifs options, it wouldn’t create one or surface any errors other than an empty gif file

I know it may be too late, but I think I have found the reason for the problem.

In the timer settings, you did enable the first and the last frame options. SnapMotion failed to get the last frame and stopped the GIF creation process.

Let me know if it just works when disabling the options.


Sorry for responding so late, I haven’t been making too many gifs. I did try turning off the last frame options. But I’m finding that it’s really rough trying to figure out the combination of settings that wouldn’t cause an empty file. I’ve attached a sample where it is failing to do any conversion or has any output that conversion failed. Maybe I’m trying to capture too much but there’s no clear line and the interval in file writing and timer seem to contradict each other.

I can upload an image but it’s worth seeing the video that I’ve made. Which I can send if you want so maybe you can see where I am getting confused in your flow.

If the application cannot create the Gif, it means that the app fails to extract some images. Is it possible to send me a sample file so that I will investigate the problem? (