Does not save changes to documents in the Finder

Feeling really stupid, but I did the following:

  • created a preset (copy EXIF date to File created date…)
  • applied the preset using the lightning bolt icon…to 350+ files
  • saw that the File Created date was modified in all of them as expected
  • go to Finder and discover that NO…the Created Date is the same as when I started


1 Like

Hello there,

Thank you for the feedback. I am sorry for the issue.

Nothing seems wrong. Do you have the same problem with 1 file, 10 files, 100 files? Did you enable the full disk access to MetaImage?

Yes, I enabled full disk access. And the same thing happened with 1, 10, 100 files. Tolkk 60 minutes trying all manner of restarts and remounts.

Finally solved my problem using command line and the open source ExifTool.

Wish you would refund me my money paid for what was a useless piece of software.


Just two idiot questions: Does the change appear in orange in the interface? Does the orange disappear after you clicked on save changes?

Wish you would refund me my money paid for what was a useless piece of software.

I’m sure the problem will be fixed very quickly if you help us understand what’s going on. However, in order to get a refund, the only step is to contact the platform where your purchased the app if you did not purchase it on our website. If purchased on our website, you can send me a private message to inform me about the email linked to your license.

It does, then when I press the “download” styled button next to the files (which I assume = “save changes”) the relevant fields turns to black in the inspector window.

This is exactly how it works.

I have noted the problem. I will do more tests this weekend.

Same issue here. Running OS Ventura on an M1 Mac Mini. Program seems to do what it should with all edits, but ultimately DOES NOT actually save the edits to the file.

I’m currently working on having the MetaImage program rename all file creation dates of my photos to the EXIF original date taken. The program says the edits have been made (also making sure to apply said edits), but the file doesn’t actually change. I’ve also made sure to allow full disk access to the program.

What’s the problem here, MetaImage???

As you see above, Jeremy responded 15 days ago that he would do more tests, but nothing since then. Ultimately I resorted to using the Terminal app and downloading a command line script/program ExifTool. It worked fine once I brushed off the cobwebs regarding how to use Terminal.

1 Like

Thanks for the tip! I also discovered another paid program that works wonders for this sort of task. It’s called “A Better Finder Attributes” - works awesome for about the same cost. That said, I really like the interface of MetaImage a bit more. What a shame :frowning:

Hello there,

I am still here working on the problem. I made several changes in the update 2.2.1 released two days ago. The problem is that I cannot reproduce the problem you got. So I made modifications to the engine assuming the problematic steps but I cannot be sure that it is fixed.

PS: I haven’t been idle for the fortnight. I released four updates on ScreenToLayers, SnapMotion, PhotosRevive and MetaImage, all during the holidays in France (Christmas and New Year).

Hello there,

MetaImage saves the metadata in the original files, not in renamed copies. The only action you have to do after the editing of metadata is to click on the save button in the toolbar. The app launches the writing process in the background. The application displays a message when the writing is finished.

Once finished, you check the modification by removing and re-opening them. Your changes should appear. The only reason a change is not applied is that MetaImage detects corruptions in your files that may destroy them. In that case, the program restores the original files in their original place. You can enable the display of errors in the settings of the apps.

If the problem always comes back with the same file, you can send it to me at I will analyze it.

PS: Renaming files is not an option offered by MetaImage. I don’t want to add more options that will complicate its use. However, I am very interested in launching the renaming, in the manner of the future MetaVideo, in a bundle.

Jeremy! Excellent work. With the update, the app now functions as advertised. Thank you. Wish there was some way to do this same thing for movie files…

1 Like